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Eclipse: Why?

• Website: www.eclipse.org

• Free, open-source IDE (Integrated Development Environment) that 
runs on most modern OS

• Commonly used for developing all of type Java applications including 
Android apps
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Downloading

• https://www.eclipse.org/downloads/
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Downloading (continued)
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Downloading (continued)

• Linux → unzip it before you can start it.

• Mac → the installer is delivered as packaged application and can be 
installed and started regular Mac installation procedures.

• Windows and Mac → can run it directly via the delivered executable/ 
package application.
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Installing

• Run the installation file has been downloaded
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Installing (continued)

• Pick Eclipse IDE for Java 
Developers from the list 
and perform the 
installation.
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Installing (continued)

• Fill an intended parent 
folder where the eclipse
folder will be created

• Click the Install button
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Installing (continued)

• Wait until the 
installation finishes
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Installing (continued)

• Once it’s finished, click 
the Launch button
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Running

• The current version will be shown
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Workspace setting

• It prompts you for a workspace to store it configuration

• Select an intended/empty folder
• You may use this folder as the default one

• Click the Launch button
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Starting

• Eclipse starts

• … and show the Welcome page.
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Welcome page

• Close this page by 
clicking the x beside 
Welcome
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Donate page

• After closing the 
welcome screen, the 
app should look like 
this

• Close the tab Donate
by clicking the x
beside Donate
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Ready to go!

• After closing the tab 
Donate, the app 
should look like this
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Appearance

• By default, Eclipse ships in a light 
configuration

• If you prefer to switch to a 
Classic/Dark/System, you can 
change it via Window > Preferences 
> General > Appearance menu
• Restart your IDE afterwards, since 

some native OS styling functionality 
requires a start
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Workspace and projects

• Workspace is the physical location (file path) for storing meta-data 
and (optional) your development artifacts.
• The meta-data stored for the workspace contains preferences settings, plug-in 

specific meta data, logs etc.

• You can choose the workspace during startup of Eclipse or via the File 
> Switch Workspace > Others menu entry.

• Your projects, source files, images and other artifacts can be stored 
inside or outside your workspace.
• For example, if you use Git as version control system, you typically would 

store the Git repositories outside of the workspace.
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Workspace and projects (continued)
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User Interface

• Eclipse provides views and editors to 
navigate and change content.

• View and editors can be grouped 
into perspectives.

• Eclipse provides different perspectives for 
different tasks. The available perspectives depend 
on your installation. For Java development you 
usually use the Java Perspective, but Eclipse has 
much more predefined perspectives, e.g., 
the Debug perspective.

• Eclipse allows you to switch to another 
perspective via the Window > Perspective > Open 
Perspective > Other…​
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User Interface (continued)

• Open editors are typically shared between 
perspectives, i.e., if you have an editor open in 
the Java perspective for a certain class and switch 
to the Debug perspective, this editor stays open.

• You can switch perspectives via the Window > 
Perspective > Open Perspective > Other…​

• The main perspectives used for Java development 
are the Java perspective and 
the Debug perspective.

• The Java perspective can be opened via Window > 
Perspective > Open Perspective > Java.
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User Interface (continued)

• On the left hand side, this perspective shows the Package 
Explorer view, which allows you to browse your projects and to 
select the components you want to open in an editor via a double-
click.

• For example, to open a Java source file, open the tree under src, 
select the corresponding .java file and double-click it. This will 
open the file in the default Java editor.

• The following picture shows the default Java perspective. 
The Package Explorer view is on the left. In the middle you see the 
open editors. Several editors are stacked in the same container and 
you can switch between them by clicking on the corresponding tab. 
Via drag and drop you can move an editor to a new position in the 
Eclipse IDE.04.09.2023
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User Interface (continued)

• To the right and below the 
editor area you find more 
views which were 
considered useful by the 
developer of the 
perspective. For example, 
the Javadoc view shows 
the Javadoc of the 
selected class or method.
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User Interface (continued)

• Resetting and customizing a perspective
• A common problem is that you changed the arrangement of views 

and editors in your perspective and you want to restore its original 
state. For example, you might have closed a view. You can reset a 
perspective to its original state via 
the Window > Perspective > Reset Perspective…​

• You can change the layout and content within a perspective by 
opening or closing parts and by re-arranging them.

• To open a new part in your current perspective, use 
the Window > Show View > Other…​ . This opens the Show 
View dialog which allows you to search for certain parts.
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User Interface (continued)

• If you want to reset your current perspective to its default, use 
the Window > Perspective > Reset Perspective…

• You can save the currently selected perspective via Window > 
Perspective > Save Perspective As…​
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User Interface (continued)

• The Window > 
Perspective > Customize 
Perspective…​ menu entry 
allows you to adjust the 
selected perspective. For 
example, you can hide or show 
toolbar and menu entries.
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User Interface (continued)

• A view is typically used to display structured data and allow to modify 
it directly.

• For example, the Project Explorer view allows you to browse and 
modify files of Eclipse projects. If you rename a file via the Project 
Explorer the file name is directly changed without having to save.

• Editors are typically used to modify a single data element, for example 
a text file. To apply these changes to the underlying data mode, you 
need to select save from the menu or the toolbar. An editor with 
unsaved data (a dirty editor) is marked with an asterisk (*) left to the 
name of the modified file. E.g., *MyFirstClass.java
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User Interface (continued)

• Eclipse projects
• An Eclipse project contains source, configuration and binary files related to a 

certain task. It groups them into buildable and reusable units. An Eclipse 
project can have natures assigned to it which describe the purpose of this 
project. For example, the Java nature defines a project as Java project. 
Projects can have multiple natures combined to model different technical 
aspects.

• Natures for a project are defined via the .project file in the project 
directory.
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Java perspective

• Package Explorer view
• The Package Explorer view allows you to browse the structure of your 

projects and to open files in an editor via a double-click on the file.

• It is also used to change the structure of your project. For example, you can 
rename files or move files and folders via drag and drop. A right-click on a file 
or folder shows you the available options.

• Outline view
• The Outline view shows the structure of the currently selected source file.
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Java perspective (continued)

• Problems view
• The Problems view shows errors and warning messages. Sooner or 

later you will run into problems with your code or your project setup. To 
view the problems in your project, you can use the Problems view 
which is part of the standard Java perspective. If this view is closed, 
you can open it via Window > Show View > Problems.

• The messages which are displayed in the Problems view can be 
configured via the drop-down menu of the view. For example, to display 
the problems from the currently selected project, select Filters… and 
set the Scope to On elements in selected projects.
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Java perspective (continued)
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Java perspective (continued)

• The Problems view also allows you to trigger a Quick fix via a 
right mouse-click on several selected messages.
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Java perspective (continued)

• Javadoc view
• The Javadoc view shows the documentation of the selected element in 

the Java editor.
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Java perspective (continued)

• Java editor
• The Java editor is used to modify the Java source code. Each Java 

source file is opened in a separate editor.

• If you right click in the left column of the editor, you can configure its 
properties, for example, that line number should be displayed.
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1st Java program

• Create project
• Select File > New > Java Project from the menu. Enter MyFirstProject as 

the project name and press the Finish button to create the project.
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1st Java program (cont’d)

• A new project is created and 
displayed as a folder. Open the 
MyFirstProject folder and 
explore the content of this folder.

• The project is typically named 
the same as the top-level Java 
package in the project. This 
makes it easier to find a project 
related to a piece of code.
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1st Java program (cont’d)

• Create package
• A good naming convention is to use the same 

name for the top level package and the 
project. For example, if you name your project 
myproject you should also use myproject as 
the top-level package name.
• By convention, package names usually start with a 

lowercase letter
• Since we have chosen MyFirstProject as our 

project name then we will use myFirstProject
as our top level package

• Create the myFirstProject package by 
selecting the src folder, right-click on it and 
select New > Package.
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1st Java program (cont’d)

• Press the Finish button
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1st Java program (cont’d)

• Create Java class
• Right-click on your package and select New > Class to create a Java 

class.
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1st Java program (cont’d)

• Enter MyFirstClass as the 
class name and select the public 
static void main (String[] args)
checkbox.

• Click the Finish button
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1st Java program (cont’d)

• This creates a new file and opens the Java editor. Change the class 
based on the following listing.

• You could also directly create new packages via this dialog. If 
you enter a new package in this dialog, it is created 
automatically.
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1st Java program (cont’d)

• Run your application code from the 
IDE
• Now run your code. Either right-click 

on your Java class in the Package 
Explorer or right-click in the Java 
class and select Run As > Java 
application.
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1st Java program (cont’d)

• Eclipse will run your Java program. You should see the output in 
the Console view.

• Congratulations! You created your first Java project, a package, 
a Java class and you ran this program inside Eclipse! 👍😊
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Run Java program outside Eclipse

• Create JAR file
• To run the Java program outside of the Eclipse IDE, you need to export it as 

a JAR file. A JAR file is the standard distribution format for Java applications.

• Select your project, right-click it and select the Export menu entry.
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Run Java program outside Eclipse (cont’d)

• Select JAR file and select the Next
button

• Select your project and enter the 
export destination and a name for 
the JAR file, for example
myprogram1.jar
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Run Java program outside Eclipse (cont’d)

• Press the Finish button

• This creates a JAR file in your 
selected output directory.
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Run Java program outside Eclipse (cont’d)

• Open a command shell, e.g., under Microsoft Windows 
select Start > Run and type cmd and press the Enter key

• This should open a console window.

• Switch to the directory which contains the JAR file, by typing cd path

• For example, if your JAR is located in D:\ITS\2021 ITS\08 

OOP\Program, use the following command.
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Run Java program outside Eclipse (cont’d)

• To run this program, include the JAR file in your classpath. 
The classpath defines which Java classes are available to the 
Java runtime.

• You can add a JAR file to the classpath with the -classpath or -cp

option.

• Type the above command in the directory you used for the 
export and you see the Hello Eclipse! output in your 
command shell.
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Project, packages & import statements (1)

• Create project
• Create a new project called counter

• Creating the following packages
• util

• main

• Create classes
• Create the following Counter class in the *.util package
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Project, packages & import statements (2)

• Create the following Tester class in the *.main package. This is a 
simple class without the usage of any unit testing framework like 
JUnit.

• The Eclipse editor should mark the created class with an error 
because the required import statements are missing.
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Project, packages & import statements (3)

• Right-click in your Java editor 
and select Source > Organize 
Imports to add the required 
import statements to your Java 
class.
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Project, packages & import statements (4)

• Or, simply click menu Source 
> Organize Imports to add the 
required import statements to 
your Java class.
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Project, packages & import statements (5)

• And choose Import ‘Counter’ (util)
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Project, packages & import statements (6)

• Alternatively, you may hover your mouse 
at the code which red colour underline 
and you will see the error’s description. 
That red colour marker before the line 
number also can be clicked to show the 
error’s description – as another 
alternative

• And choose Import ‘Counter’ (util)
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Project, packages & import statements (7)

• This should remove the syntax error. Finish the implementation for 
the Tester class based on the following code.
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Project, packages & import statements (8)

• The Counter class had in its 
source code a comment starting 
with TODO. Finish the source code 
and calculate the correct values.

• Run the Tester class and validate 
that your implementation is 
correct. The Tester class checks 
for an example value but the 
method should work for different 
input values.
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Project, packages & import statements (9)

• An example of the 
solution
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Exporting & importing projects

• Exporting projects
• You can export and import Eclipse 

projects. This allows you to share 
projects with other people and to import 
existing projects.

• To export Eclipse projects, 
select File > Export > General > Archive 
File and select the projects you want to 
export.
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Exporting & importing projects (cont’d)
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Exporting & importing projects (cont’d)

• Importing projects
• To import projects, 

select File > Import > Existing 
Projects into Workspace. You 
can import from an archive file, 
i.e., zip file or directly import the 
projects in case you have 
extracted the zip file.
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Exporting & importing projects (cont’d)

• Exercise 1
• Importing project(s) can be done if the 

project(s) hasn’t existed in our 
Workspace

• Delete the existing one(s) before 
importing the project(s). Make sure the 
project(s) has already been exported 
(zipped) before deleting it.

• Exercise 2
• Export one of your projects into a zip file. 

Switch into a new workspace and import 
the project into your new workspace 
based on the zip file you exported.
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Source navigation

• Package Explorer or Project Explorer
• The primary way of navigating through your project is the Package 

Explorer or alternatively the Project Explorer view. You can open nodes 
in the tree and open a file in an editor by double-clicking on the 
corresponding entry in the tree hierarchy.
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Source navigation (continued)

• The drop-down menu in the Package 
Explorer allows you to filter the resources 
which should be displayed or hidden.

04.09.2023
2023/2024(1) – Object Oriented Programming | MM Irfan 

Subakti
63



Link Package Explorer with editor

• The Package Explorer view allows you to 
display the associated file from the currently 
selected editor. For example, if you are 
working on the Tester.java file in the Java 
editor and switch to the Java editor of the 
Counter.java file, then the corresponding 
file will be selected in the Package Explorer
view.

• To activate this behaviour, press the Link 
with Editor button in the Package Explorer
view as depicted in the following screenshot.
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